package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[(^?&#)]([^=]+)\=([^&#]+)`)
var str = `https://www.heatingspareparts.com/Boiler-Spares/AllPartsFor/Baxi?Search=a&page=1&more=2#hash`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}