// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+\/$|(copy)").unwrap();
let string = "https://gpe-satellite-1.pnpd.co.uk/shop/italian-grand-prix/red-bull-racing-paddock-club-friday-10/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}