# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n\s\sname:\sI_LOGON_AUTH_FAILED\n[\s\S]*?\s\ssession\n[\s\S]*?\s\s\s\sremoteAddress:\s(?<ipaddress>.*?):[0-9]*\n[\s\S]*?\s\sauthentication\n[\s\S]*?\s\s\s\suserName:\s(?<username>.*)"
test_str = ("event\n"
" time: 2021-11-23 22:42:59.164039 +0300\n"
" app: BvSshServer 8.49\n"
" name: I_LOGON_AUTH_FAILED\n"
" desc: User authentication failed.\n"
" session\n"
" id: 1015\n"
" service: SSH\n"
" remoteAddress: 192.168.0.103:41104\n"
" authentication\n"
" attemptNr: 1\n"
" serialize: completion\n"
" userName: userTest\n"
" method: keyboard-interactive\n"
" submethod: Password\n"
" windowsAccount: DESKTOP-FN3LTFE\\paprikar\n"
" parameters\n"
" failureReason: BadCredentials\n"
" help\n"
" message: Unknown user name or incorrect password.\n")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.