const regex = /\n\s\sname:\sI_LOGON_AUTH_FAILED\n[\s\S]*?\s\ssession\n[\s\S]*?\s\s\s\sremoteAddress:\s(?<ipaddress>.*?):[0-9]*\n[\s\S]*?\s\sauthentication\n[\s\S]*?\s\s\s\suserName:\s(?<username>.*)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n\\s\\sname:\\sI_LOGON_AUTH_FAILED\\n[\\s\\S]*?\\s\\ssession\\n[\\s\\S]*?\\s\\s\\s\\sremoteAddress:\\s(?<ipaddress>.*?):[0-9]*\\n[\\s\\S]*?\\s\\sauthentication\\n[\\s\\S]*?\\s\\s\\s\\suserName:\\s(?<username>.*)', 'i')
const str = `event
time: 2021-11-23 22:42:59.164039 +0300
app: BvSshServer 8.49
name: I_LOGON_AUTH_FAILED
desc: User authentication failed.
session
id: 1015
service: SSH
remoteAddress: 192.168.0.103:41104
authentication
attemptNr: 1
serialize: completion
userName: userTest
method: keyboard-interactive
submethod: Password
windowsAccount: DESKTOP-FN3LTFE\\paprikar
parameters
failureReason: BadCredentials
help
message: Unknown user name or incorrect password.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}