$re = '/#[abcdef0-9]{3,6}/';
$str = 'color: #fff;
color: black;
color: #f5f5f5;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);