package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#[abcdef0-9]{3,6}`)
var str = `color: #fff;
color: black;
color: #f5f5f5;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}