$re = '/(http|https|ftp|sftp):\/\/(www\.)*(\w\.)*\w+\.(\w){1,3}(:\d{1,4})*(\/*)[a-zA-Z0-9_.?&= %]*/m';
$str = 'http://google.com
https://www.google.com
http://www.google.com/search
ftp://test.test.example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);