package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http|https|ftp|sftp):\/\/(www\.)*(\w\.)*\w+\.(\w){1,3}(:\d{1,4})*(\/*)[a-zA-Z0-9_.?&= %]*`)
var str = `http://google.com
https://www.google.com
http://www.google.com/search
ftp://test.test.example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}