$re = '/(?<=^Z_).*/mi';
$str = 'Z_ljsfklhdsf_dslfkjsdf
Z_asfd_Z_jkfdsahksdf
ZZ_sdfsdfsdf
z_asfdlkjsdkf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);