using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^Z_).*";
string input = @"Z_ljsfklhdsf_dslfkjsdf
Z_asfd_Z_jkfdsahksdf
ZZ_sdfsdfsdf
z_asfdlkjsdkf
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}