import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(\\d|[1-9]+\\d*|\\.\\d+|0\\.\\d+|[1-9]+\\d*\\.\\d+)$";
final String string = "0\n"
+ "5\n"
+ "50\n"
+ ".5\n"
+ ".05\n"
+ "5.5\n"
+ "5.05\n"
+ "5.050\n"
+ "5.50\n"
+ "0.5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}