#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(\d|[1-9]+\d*|\.\d+|0\.\d+|[1-9]+\d*\.\d+)$"
Local $sString = "0" & @CRLF & _
"5" & @CRLF & _
"50" & @CRLF & _
".5" & @CRLF & _
".05" & @CRLF & _
"5.5" & @CRLF & _
"5.05" & @CRLF & _
"5.050" & @CRLF & _
"5.50" & @CRLF & _
"0.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")