const regex = /\d{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}', 'g')
const str = `000,723,45,4545
ASDF010101HTLRSL01
QWER121217HTLRSE03`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}