use strict;
my $str = '0.0.0.0/0 *[OSPF/150] 5w2d 19:06:26, metric 24, tag 100
to 10.239.248.129 via ae101.0
> to 10.239.248.137 via ae102.0
1.1.21.0/30 *[OSPF/10] 5w2d 19:06:26, metric 23
> to 10.239.248.129 via ae101.0
to 10.239.248.137 via ae102.0
[BGP/170] 10w3d 08:00:01, localpref 260, from 189.40.251.20
AS path: 17379 I, validation-state: unverified
> to 10.239.248.129 via ae101.0, Push 16151
to 10.239.248.137 via ae102.0, Push 16109
[BGP/170] 10w3d 08:00:54, localpref 260, from 189.40.251.21
AS path: 17379 I, validation-state: unverified
> to 10.239.248.129 via ae101.0, Push 16151
to 10.239.248.137 via ae102.0, Push 16109
1.1.21.4/30 *[OSPF/10] 5w2d 19:06:26, metric 23
to 10.239.248.129 via ae101.0
> to 10.239.248.137 via ae102.0
[BGP/170] 10w3d 07:57:12, MED 120, localpref 100, from 189.40.251.21
AS path: ?, validation-state: unverified
> to 10.239.248.129 via ae101.0
[BGP/170] 10w3d 07:56:39, MED 120, localpref 100, from 189.40.251.20
AS path: ?, validation-state: unverified
';
my $regex = qr/^[\d.]+\/\d\d\S*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}