const regex = new RegExp('^[\\d.]+\\/\\d\\d\\S*', 'gm')
const str = `0.0.0.0/0 *[OSPF/150] 5w2d 19:06:26, metric 24, tag 100
to 10.239.248.129 via ae101.0
> to 10.239.248.137 via ae102.0
1.1.21.0/30 *[OSPF/10] 5w2d 19:06:26, metric 23
> to 10.239.248.129 via ae101.0
to 10.239.248.137 via ae102.0
[BGP/170] 10w3d 08:00:01, localpref 260, from 189.40.251.20
AS path: 17379 I, validation-state: unverified
> to 10.239.248.129 via ae101.0, Push 16151
to 10.239.248.137 via ae102.0, Push 16109
[BGP/170] 10w3d 08:00:54, localpref 260, from 189.40.251.21
AS path: 17379 I, validation-state: unverified
> to 10.239.248.129 via ae101.0, Push 16151
to 10.239.248.137 via ae102.0, Push 16109
1.1.21.4/30 *[OSPF/10] 5w2d 19:06:26, metric 23
to 10.239.248.129 via ae101.0
> to 10.239.248.137 via ae102.0
[BGP/170] 10w3d 07:57:12, MED 120, localpref 100, from 189.40.251.21
AS path: ?, validation-state: unverified
> to 10.239.248.129 via ae101.0
[BGP/170] 10w3d 07:56:39, MED 120, localpref 100, from 189.40.251.20
AS path: ?, validation-state: unverified
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}