import Foundation
let pattern = #"<span style=(?:\\){0,2}"--en-type:(?:\s)??tag;--en-tagId:(?:\s)?([^\/\\;]+)(?:;)?(?:\\){0,2}">([^<>]+)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<!DOCTYPE en-note SYSTEM "http://xml.evernote.com/pub/enml2.dtd"><en-note><p><span style="--en-type:tag;--en-tagId:17436cb0-7873-4317-8453-623e7f3a5dd1;">#234234<>&</span> <span style="--en-type:tag;--en-tagId:ed628b06-297b-4411-9266-3e5fa64f4f5c;">#21423<>14n</span> <span style="--en-type:tag;--en-tagId:27f5d787-9e2a-4d66-9c6e-1f938aa60834;">#2423432</span> </p></en-note>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}