# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<span style=(?:\\){0,2}\"--en-type:(?:\s)??tag;--en-tagId:(?:\s)?([^\/\\;]+)(?:;)?(?:\\){0,2}\">([^<>]+)<\/span>"
test_str = "<!DOCTYPE en-note SYSTEM \"http://xml.evernote.com/pub/enml2.dtd\"><en-note><p><span style=\"--en-type:tag;--en-tagId:17436cb0-7873-4317-8453-623e7f3a5dd1;\">#234234<>&</span> <span style=\"--en-type:tag;--en-tagId:ed628b06-297b-4411-9266-3e5fa64f4f5c;\">#21423<>14n</span> <span style=\"--en-type:tag;--en-tagId:27f5d787-9e2a-4d66-9c6e-1f938aa60834;\">#2423432</span> </p></en-note>"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.