re = /(\d+)\s*متر/m
str = 'زیرزمین ۱۳۰ متری تک خواب نقاشی شده وتمیز بلوار فلسطین
شهرک فرهنگیان ۲م رهن با ۸۵۰ت
فقط خانواده
املاک عباسی ۳۸۲۰۱۳۱۳'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end