using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s*متر";
string input = @"زیرزمین ۱۳۰ متری تک خواب نقاشی شده وتمیز بلوار فلسطین
شهرک فرهنگیان ۲م رهن با ۸۵۰ت
فقط خانواده
املاک عباسی ۳۸۲۰۱۳۱۳";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}