$re = '/^([0-9]|[1-9]*)$/m';
$str = '3
44
55.5
66.66
777
3,3
.4
.55
-7
89.80
9.234
0
00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);