import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]|[1-9]*)$";
final String string = "3\n"
+ "44\n"
+ "55.5\n"
+ "66.66\n"
+ "777\n"
+ "3,3\n"
+ ".4\n"
+ ".55\n"
+ "-7\n"
+ "89.80\n"
+ "9.234\n"
+ "0\n"
+ "00\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}