use strict;
my $str = '2021/01/14 16:57:33 - Copy rows to result.0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)';
my $regex = qr/(?<time>[^ ]* [^-]*) - +(?<name>[^-]*) - (?<message>[^ ]*.*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}