#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<time>[^ ]* [^-]*) - +(?<name>[^-]*) - (?<message>[^ ]*.*$)"
Local $sString = "2021/01/14 16:57:33 - Copy rows to result.0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")