import Foundation
let pattern = #"^(?:(?:(0?[13578]|1[02])([\-.\/])(0?[1-9]|[12][0-9]|3[01])|(0?[469]|11)([\-.\/])(0?[1-9]|[12][0-9]|30)|(0?2)([\-.\/])(0?[1-9]|[12][0-9]))(?:\2|\5|\8)((?:16|[357][26]|[2468][048])(?:[0248][048]|[13579][26])|(?:1[6-9]|[2-9][0-9])(?:0[48]|[13579][26]|[2468][048])|(?:15)(?:84|9[048]))|(?:(0?[13578]|1[02])([\-.\/])(0?[1-9]|[12][0-9]|3[01])|(0?[469]|11)([\-.\/])(0?[1-9]|[12][0-9]|30)|(0?2)([\-.\/])(0?[1-9]|1[0-9]|2[0-8]))(?:\12|\15|\18)((?:16|[357][26]|[2468][048])(?:0[1235679]|[13579][01345789]|[2468][1235679])|(?:1[789]|[35679][01345789]|[248][12345679])(?:0[01235679]|[13579][01345789]|[2468][1235679])|(?:15)(?:8[235679]|9[01345789])))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2-2-2016"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)