import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(0?[13578]|1[02])([\\-.\\/])(0?[1-9]|[12][0-9]|3[01])|(0?[469]|11)([\\-.\\/])(0?[1-9]|[12][0-9]|30)|(0?2)([\\-.\\/])(0?[1-9]|[12][0-9]))(?:\\2|\\5|\\8)((?:16|[357][26]|[2468][048])(?:[0248][048]|[13579][26])|(?:1[6-9]|[2-9][0-9])(?:0[48]|[13579][26]|[2468][048])|(?:15)(?:84|9[048]))|(?:(0?[13578]|1[02])([\\-.\\/])(0?[1-9]|[12][0-9]|3[01])|(0?[469]|11)([\\-.\\/])(0?[1-9]|[12][0-9]|30)|(0?2)([\\-.\\/])(0?[1-9]|1[0-9]|2[0-8]))(?:\\12|\\15|\\18)((?:16|[357][26]|[2468][048])(?:0[1235679]|[13579][01345789]|[2468][1235679])|(?:1[789]|[35679][01345789]|[248][12345679])(?:0[01235679]|[13579][01345789]|[2468][1235679])|(?:15)(?:8[235679]|9[01345789])))$";
final String string = "2-2-2016";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}