re = /Invoice ((?:[0-9]){8})/m
str = 'THIS IS AN EXAMPLES OF Invoice Email Subject sample
Harmonie Mutuelle - Invoice 1234567890123456
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end