$re = '/Invoice ((?:[0-9]){8})/m';
$str = 'THIS IS AN EXAMPLES OF Invoice Email Subject sample
Harmonie Mutuelle - Invoice 1234567890123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);