$re = '/([A-Z][0-9][0-9])([A-Z])([0-9][0-9])([A-Z])/m';
$str = 'F01C05B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);