package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z][0-9][0-9])([A-Z])([0-9][0-9])([A-Z])`)
var str = `F01C05B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}