const regex = /(\d+\.\d+)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\.\\d+)\\s', 'gm')
const str = `165.1 x 75.6 x 8.9 mm (6.5 x 2.98 x 0.35 in)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}