package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+\.\d+)\s`)
var str = `165.1 x 75.6 x 8.9 mm (6.5 x 2.98 x 0.35 in)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}