# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Remarks: ([^\r]+)Members:"
test_str = ("GBRG0A 00005 JULIEx 11/27/17 11:03:12 X3311073-00X DAMAGE\n\n"
"Dig No : X3311073 Rev : 00X Digstart: 11/27/17 11:01\n"
"Rcvd : 11/27/17 11:03 Priority: 0 Expires : 12/24/17 23:59\n"
"Org Dig: X3311073 Rcvd: 11/27/17 11:01\n\n"
"Firm : KNOX CONSTRUCTION Caller: DUSTIN KNOX\n"
"CoAddr1: 1386 BRIDGEPORT RD\n"
"City,St: MAQUON, IL Zip : 61458\n"
"Phone : 309-337-6576 Ext :\n"
"Call Bk: Done For : PATTY BAILEY\n"
"SiteCnt: DUSTIN KNOX Phone : 309-337-6576\n\n"
"County : KNOX Place: GALESBURG CIT\n"
"Address: 522 ISLE ROYALE RD\n"
"Subdiv : Cross: LOSEY ST\n\n"
"Grids : T11NR01E09SW\n\n"
"BestFit: 40.954957/-90.400618 40.954938/-90.399043\n"
" : 40.953819/-90.400632 40.953799/-90.399057\n"
"PreMark: YES Directional Boring: NO Depth>7Ft: NO\n"
"Locatn : IN THE CITY OF GALESBURG,\n"
"WrkType: FENCE POST INSTALLATION ***HIT LINE****\n"
"Extent : LOCATE: THE WEST SIDE OF THE HOUSE.\n"
"Remarks: REFER TO DIG# X003241591 TO ALL COMPANIES, CALLER STATES HIT A\n"
" : MISMARKED CENTURY LINK LINE. CREW IS ON SITE. CALLED IN BY DUSTIN.\n\n"
"Members: COMC0A GBRG0A GSD0A GSD0B IPC6A SCNT3A USIC0A\n\n"
"View map at:\n"
"http://newtin.julie1call.com/newtinweb/map_tkt.nap?TRG=32WSVUQRTTVORRtwo2")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.