#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Remarks: ([^\r]+)Members:"
Local $sString = "GBRG0A 00005 JULIEx 11/27/17 11:03:12 X3311073-00X DAMAGE" & @CRLF & _
"" & @CRLF & _
"Dig No : X3311073 Rev : 00X Digstart: 11/27/17 11:01" & @CRLF & _
"Rcvd : 11/27/17 11:03 Priority: 0 Expires : 12/24/17 23:59" & @CRLF & _
"Org Dig: X3311073 Rcvd: 11/27/17 11:01" & @CRLF & _
"" & @CRLF & _
"Firm : KNOX CONSTRUCTION Caller: DUSTIN KNOX" & @CRLF & _
"CoAddr1: 1386 BRIDGEPORT RD" & @CRLF & _
"City,St: MAQUON, IL Zip : 61458" & @CRLF & _
"Phone : 309-337-6576 Ext :" & @CRLF & _
"Call Bk: Done For : PATTY BAILEY" & @CRLF & _
"SiteCnt: DUSTIN KNOX Phone : 309-337-6576" & @CRLF & _
"" & @CRLF & _
"County : KNOX Place: GALESBURG CIT" & @CRLF & _
"Address: 522 ISLE ROYALE RD" & @CRLF & _
"Subdiv : Cross: LOSEY ST" & @CRLF & _
"" & @CRLF & _
"Grids : T11NR01E09SW" & @CRLF & _
"" & @CRLF & _
"BestFit: 40.954957/-90.400618 40.954938/-90.399043" & @CRLF & _
" : 40.953819/-90.400632 40.953799/-90.399057" & @CRLF & _
"PreMark: YES Directional Boring: NO Depth>7Ft: NO" & @CRLF & _
"Locatn : IN THE CITY OF GALESBURG," & @CRLF & _
"WrkType: FENCE POST INSTALLATION ***HIT LINE****" & @CRLF & _
"Extent : LOCATE: THE WEST SIDE OF THE HOUSE." & @CRLF & _
"Remarks: REFER TO DIG# X003241591 TO ALL COMPANIES, CALLER STATES HIT A" & @CRLF & _
" : MISMARKED CENTURY LINK LINE. CREW IS ON SITE. CALLED IN BY DUSTIN." & @CRLF & _
"" & @CRLF & _
"Members: COMC0A GBRG0A GSD0A GSD0B IPC6A SCNT3A USIC0A" & @CRLF & _
"" & @CRLF & _
"View map at:" & @CRLF & _
"http://newtin.julie1call.com/newtinweb/map_tkt.nap?TRG=32WSVUQRTTVORRtwo2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")