const regex = new RegExp(',.*', 'gm')
const str = `ATLANTA, GA`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);