$re = '/(([A-F][0-9]|[0-9]{2}|[0-9][A-F]|[A-F]{2})|(\?))(\s|)/m';
$str = '81 F9 00 00 00 00 75 1D F3 0F 10 05 00 00 00 00 F3 0F 11 44 24 00 8B 44 24 18 35 00 00 00 00 89 44 24 0C EB 0B';
$subst = "\\x$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;