import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([A-F][0-9]|[0-9]{2}|[0-9][A-F]|[A-F]{2})|(\\?))(\\s|)";
final String string = "81 F9 00 00 00 00 75 1D F3 0F 10 05 00 00 00 00 F3 0F 11 44 24 00 8B 44 24 18 35 00 00 00 00 89 44 24 0C EB 0B";
final String subst = "\\\\x$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}