# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{\"time\": \"([^\"]+)\", \"remote_addr\": \"([^\"]+)\", \"x_forward_for\": \"([^\"]+)\", \"request_id\": \"([^\"]+)\", \"remote_user\": \"([^\"]+)\", \"bytes_sent\": (\d+), \"request_time\": ([\d.]+), \"status\": (\d+), \"vhost\": \"([^\"]+)\", \"request_proto\": \"([^\"]+)\", \"path\": \"([^\"]+)\", \"request_query\": \"([^\"]+)\", \"request_length\": (\d+), \"duration\": ([\d.]+),\"method\": \"([^\"]+)\", \"http_referrer\": \"([^\"]+)\", \"http_user_agent\": \"([^\"]+)\", \"proxy_upstream_name\": \"([^\"]+)\", \"service_name\": \"([^\"]+)\"}"
test_str = "{\"time\": \"2023-09-02T13:06:07+00:00\", \"remote_addr\": \"127.0.0.6\", \"x_forward_for\": \"127.0.0.6\", \"request_id\": \"08aaccca-f6e7-4480-9f7b-d157f1dce306\", \"remote_user\": \"-\", \"bytes_sent\": 277, \"request_time\": 0.386, \"status\": 200, \"vhost\": \"10.160.96.120\", \"request_proto\": \"HTTP/1.1\", \"path\": \"/savethesale/v1/validateemployee/243060/couponmgmt\", \"request_query\": \"-\", \"request_length\": 423, \"duration\": 0.384,\"method\": \"GET\", \"http_referrer\": \"-\", \"http_user_agent\": \"PostmanRuntime/7.32.3\", \"proxy_upstream_name\": \"ns-sell-save-the-sale-9097\", \"service_name\": \"save-the-sale\"}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.