use strict;
my $str = '{"time": "2023-09-02T13:06:07+00:00", "remote_addr": "127.0.0.6", "x_forward_for": "127.0.0.6", "request_id": "08aaccca-f6e7-4480-9f7b-d157f1dce306", "remote_user": "-", "bytes_sent": 277, "request_time": 0.386, "status": 200, "vhost": "10.160.96.120", "request_proto": "HTTP/1.1", "path": "/savethesale/v1/validateemployee/243060/couponmgmt", "request_query": "-", "request_length": 423, "duration": 0.384,"method": "GET", "http_referrer": "-", "http_user_agent": "PostmanRuntime/7.32.3", "proxy_upstream_name": "ns-sell-save-the-sale-9097", "service_name": "save-the-sale"}';
my $regex = qr/{"time": "([^"]+)", "remote_addr": "([^"]+)", "x_forward_for": "([^"]+)", "request_id": "([^"]+)", "remote_user": "([^"]+)", "bytes_sent": (\d+), "request_time": ([\d.]+), "status": (\d+), "vhost": "([^"]+)", "request_proto": "([^"]+)", "path": "([^"]+)", "request_query": "([^"]+)", "request_length": (\d+), "duration": ([\d.]+),"method": "([^"]+)", "http_referrer": "([^"]+)", "http_user_agent": "([^"]+)", "proxy_upstream_name": "([^"]+)", "service_name": "([^"]+)"}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}