$re = '/^$|^(\d+(?:[\.\,]\d{1,2})?)$/m';
$str = '253,25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);