package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^$|^(\d+(?:[\.\,]\d{1,2})?)$`)
var str = `253,25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}