$re = '/Redirecting to .*?\?from=(?P<from>[\.a-z0-9]+)&exportFileName=(?P<exportFileName>[\.a-z0-9]+)(?:&to=(?P<to>[\.a-z0-9]+))?(?:\&lang=(?P<lang>[a-z]+))?(?:\&action=(?P<action>[a-z\-]+))?/X';
$str = 'Redirecting to /en/replacementOverview/?from=fa1e3273f2a2e5e8771dbd1ac8d0883f.xml&exportFileName=source.en.xlf&to=f2c3513085b9bda6012e5ce48e46a38d.xml&lang=de&action=overview-test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);