#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?X)Redirecting to .*?\?from=(?P<from>[\.a-z0-9]+)&exportFileName=(?P<exportFileName>[\.a-z0-9]+)(?:&to=(?P<to>[\.a-z0-9]+))?(?:\&lang=(?P<lang>[a-z]+))?(?:\&action=(?P<action>[a-z\-]+))?"
Local $sString = "Redirecting to /en/replacementOverview/?from=fa1e3273f2a2e5e8771dbd1ac8d0883f.xml&exportFileName=source.en.xlf&to=f2c3513085b9bda6012e5ce48e46a38d.xml&lang=de&action=overview-test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")