re = /^[!?;.]([^!?;.]*)*?\s+[-:'",]*([a-zа-я-]*?)([-:'",]+\s|\s)+?([^!?;.]*\s+)*([-:'",]*)*\2/m
str = '. мама- мама'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end