$re = '/^[!?;.]([^!?;.]*)*?\s+[-:\'",]*([a-zа-я-]*?)([-:\'",]+\s|\s)+?([^!?;.]*\s+)*([-:\'",]*)*\2/m';
$str = '. мама- мама';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);