$re = '/\/(|en-US|en-GB|en-AU|fr-CA|en-CA|es-MX|tr-TR)*\/*(legal-platform)\/+/m';
$str = '/legal-platform/sdcdscs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);