using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(|en-US|en-GB|en-AU|fr-CA|en-CA|es-MX|tr-TR)*\/*(legal-platform)\/+";
string input = @"/legal-platform/sdcdscs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}