use strict;
my $str = '/BACK/ubi_sips_intranet/ubi-intranet-ticketing/conf/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_web_ticketing
/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/wlp_online_watcher?useUnicode=true&cacheResultSetMetadata=true
/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/wlp_online_watcher?useUnicode=true&cacheResultSetMetadata=true
/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/openejb.xml: JdbcUrl jdbc:sybase:Tds:bsbfi008v:13420/payment
/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_rms_param?useUnicode=true&cacheResultSetMetadata=true
/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/spring-beans.xml: <property name="url" value="jdbc:sybase:Tds:bsbfi008v:13420/payment" />
/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/spring-beans.xml: <property name="url" value="jdbc:sybase:Tds:/payment_data" />
/BACK/ubz_oppotota/alimentation-oppotota/properties/openejb.xml: JdbcUrl jdbc:sybase:Tds:bsbfi008v:13420/sips_oppotota
/BACK/ubz_oppotota/alimentation-oppotota/properties/openejb.xml: JdbcUrl jdbc:oracle:thin:@//vsbficrs11db-scan.vdm.qvmbfi.svc.meshcore.net:1522/SN_SIPS_OPPOTOTA_NRT
/BACK/ubz_sips_batch/ubz-fraud/properties/fwk-opm.xml: <url>jdbc:sybase:Tds:bsbfi008v:13420/payment</url>
/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/wlp_online_watcher?useUnicode=true&cacheResultSetMetadata=true
/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/wlp_online_watcher?useUnicode=true&cacheResultSetMetadata=true
/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_merchants?useUnicode=true&cacheResultSetMetadata=true
/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_rms_param?useUnicode=true&cacheResultSetMetadata=true
/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:sybase:Tds:bsbfi008v:13420/payment_data
/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:sybase:Tds:bsbfi008v:13420/payment
/BACK/ubz_sips_batch/ubz-fraud/properties/spring-beans.xml: <property name="url" value="jdbc:sybase:Tds:bsbfi008v:13420/payment" />
/BACK/ubz_sips_batch/ubz-fraud/properties/spring-beans.xml: <property name="url" value="jdbc:sybase:Tds:bsbfi008v:13420/payment_data" />
/BACK/ubz_bdd/sips_stat_iga/param/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_stat_iga
/BACK/ubz_bdd/sips_stat_iga/param/openejb.xml: JdbcUrl jdbc:mysql://127.0.0.1:3306/sips_stat_iga
/BACK/ubz_bdd/sips_stat_iga/param/openejb.xml: JdbcUrl jdbc:mysql://bqsips31v:3306/sips_stat_iga
/BACK/ubz_bdd/sips_stat_iga.old/param/openejb.xml: JdbcUrl jdbc:mysql://bqsips31v:3307/sips_stat_iga
/BACK/ubz_bdd/sips_stat_iga.old/param/openejb.xml: JdbcUrl jdbc:mysql://127.0.0.1:3306/sips_stat_iga
/BACK/ubz_bdd/sips_stat_iga.old/param/openejb.xml: JdbcUrl jdbc:mysql://bqsips31v:3306/sips_stat_iga
/BACK/ubz_sbo/rgi/conf/config.xml: <url>jdbc:sybase:Tds:bsbfi008v:13420/payment_account</url>';
my $regex = qr/(\/((BACK)|(MIDDLE))\/[\w_]+\/([\w_\-]+)\/(\w+\/)*[\w\-]+\.xml):\s+((JdbcUrl )|(<property name=\"url\" value=\")|(<url>))(jdbc:((mysql)|(sybase)|(oracle)):((\/\/)|(Tds:)|(thin:@\/\/))([\w\-.]+:\d+)?\/([\w_\-]+)(\?(\w+=\w+&)*(\w+=\w+))?)((\" \/>)|(<\/url>))?/p;
my $subst = '$5;$1;$13;$21';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";