import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/((BACK)|(MIDDLE))\\/[\\w_]+\\/([\\w_\\-]+)\\/(\\w+\\/)*[\\w\\-]+\\.xml):\\s+((JdbcUrl )|(<property name=\\\"url\\\" value=\\\")|(<url>))(jdbc:((mysql)|(sybase)|(oracle)):((\\/\\/)|(Tds:)|(thin:@\\/\\/))([\\w\\-.]+:\\d+)?\\/([\\w_\\-]+)(\\?(\\w+=\\w+&)*(\\w+=\\w+))?)((\\\" \\/>)|(<\\/url>))?";
final String string = "/BACK/ubi_sips_intranet/ubi-intranet-ticketing/conf/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_web_ticketing\n"
+ "/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/wlp_online_watcher?useUnicode=true&cacheResultSetMetadata=true\n"
+ "/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/wlp_online_watcher?useUnicode=true&cacheResultSetMetadata=true\n"
+ "/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/openejb.xml: JdbcUrl jdbc:sybase:Tds:bsbfi008v:13420/payment\n"
+ "/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_rms_param?useUnicode=true&cacheResultSetMetadata=true\n"
+ "/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/spring-beans.xml: <property name=\"url\" value=\"jdbc:sybase:Tds:bsbfi008v:13420/payment\" />\n"
+ "/BACK/ubi_sips_intranet/ubi-legacyfraud2rms/properties/spring-beans.xml: <property name=\"url\" value=\"jdbc:sybase:Tds:/payment_data\" />\n"
+ "/BACK/ubz_oppotota/alimentation-oppotota/properties/openejb.xml: JdbcUrl jdbc:sybase:Tds:bsbfi008v:13420/sips_oppotota\n"
+ "/BACK/ubz_oppotota/alimentation-oppotota/properties/openejb.xml: JdbcUrl jdbc:oracle:thin:@//vsbficrs11db-scan.vdm.qvmbfi.svc.meshcore.net:1522/SN_SIPS_OPPOTOTA_NRT\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/fwk-opm.xml: <url>jdbc:sybase:Tds:bsbfi008v:13420/payment</url>\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/wlp_online_watcher?useUnicode=true&cacheResultSetMetadata=true\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/wlp_online_watcher?useUnicode=true&cacheResultSetMetadata=true\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_merchants?useUnicode=true&cacheResultSetMetadata=true\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_rms_param?useUnicode=true&cacheResultSetMetadata=true\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:sybase:Tds:bsbfi008v:13420/payment_data\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/openejb.xml: JdbcUrl jdbc:sybase:Tds:bsbfi008v:13420/payment\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/spring-beans.xml: <property name=\"url\" value=\"jdbc:sybase:Tds:bsbfi008v:13420/payment\" />\n"
+ "/BACK/ubz_sips_batch/ubz-fraud/properties/spring-beans.xml: <property name=\"url\" value=\"jdbc:sybase:Tds:bsbfi008v:13420/payment_data\" />\n"
+ "/BACK/ubz_bdd/sips_stat_iga/param/openejb.xml: JdbcUrl jdbc:mysql://bqsips03v:3311/sips_stat_iga\n"
+ "/BACK/ubz_bdd/sips_stat_iga/param/openejb.xml: JdbcUrl jdbc:mysql://127.0.0.1:3306/sips_stat_iga\n"
+ "/BACK/ubz_bdd/sips_stat_iga/param/openejb.xml: JdbcUrl jdbc:mysql://bqsips31v:3306/sips_stat_iga\n"
+ "/BACK/ubz_bdd/sips_stat_iga.old/param/openejb.xml: JdbcUrl jdbc:mysql://bqsips31v:3307/sips_stat_iga\n"
+ "/BACK/ubz_bdd/sips_stat_iga.old/param/openejb.xml: JdbcUrl jdbc:mysql://127.0.0.1:3306/sips_stat_iga\n"
+ "/BACK/ubz_bdd/sips_stat_iga.old/param/openejb.xml: JdbcUrl jdbc:mysql://bqsips31v:3306/sips_stat_iga\n"
+ "/BACK/ubz_sbo/rgi/conf/config.xml: <url>jdbc:sybase:Tds:bsbfi008v:13420/payment_account</url>";
final String subst = "$5;$1;$13;$21";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}