re = /^(https:\/\/w{3}|w{3})(.)[A-Za-z]{1,25}(.com)/m
str = 'https://www.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end