package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https:\/\/w{3}|w{3})(.)[A-Za-z]{1,25}(.com)`)
var str = `https://www.google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}